首页 🖥运维&安全

Packet Tracer 常用操作命令

> en    //进入特权模式(此时为用户执行模式)
# conf t    //进入全局配置模式(此时为特权模式)
(config)#   //此时为全局配置模式
(config-if)# //接口配置模式

// 常见命令:
(config-if)# no shutdown    //开启端口

# traceroute x.x.x.x    //路由跟踪
# ping x.x.x.x          // ping 连通性测试

# show run | <include/exclude...> //查看运行配置
# show clock    //查看时钟信息
# show ip route //查看路由表
# show ip ospf neighbors   //查看ospf邻居路由
# show ip access-lists  //查看ACL
# show ip nat tr    //查看nat转发信息


// 保存配置命令:
# copy r s 
# write

// 重启命令:
# reload

注:在全局配置模式下使用特权模式的命令时,命令前要加do
      (例如 #show run ; (config)# do show run )

相关操作:

   指令错误导致的卡死:ctrl+shift+6

   

Vlan的划分与分配


(config)# vlan <vlan_id>    //创建vlan

// 将接口划分到vlan
(config)# int <interface_id>    // int range 可以同时进入多个端口(逗号分隔)
(config-if)# switchport mode access 
(config-if)# switchport access vlan <vlan_id>

// 注:若在分配时未创建vlan,则会自动创建

路由

1.什么是管理距离值(AD)?

表示路由可能通过多种协议获取相同的路由,则优先选择AD值最小的路由协议。

2.什么是度量值(Metric)?

当有多条路径可选时,路由器会计算每条路径的代价花费(metric),而路由器选取metric小的加入路由表。

注:先对AD值进行比较,再比较度量值。

默认AD值:

协议默认管理距离值(AD)
直连0
静态1
EIGRP(cisco私有)90
IGRP100
OSPF110
RIP120

静态路由

// 指令格式,度量值<metric>可省略
(config)# ip route  <destination_network> <prefix_mask> <next_address>  <metic>
(config)# ip route  <destination_network> <prefix_mask> <out_port>  <metric>

//默认路由:
(config)# ip route 0.0.0.0 0.0.0.0 <next_address/port>

动态路由

1.rip

(config)# router rip  
(config-router)# version 2
(config-router)# network   <connected_net>
(config-router)# network   <connected_net>
2.ospf

(config)# router ospf <process_id>    //<process_id> 为进程号
(config-router)# router-id x.x.x.x
// area 0 为骨干区域(必须存在)
(config-router)# network <connected_net>   <wildcard-mask>  area   0    
(config-router)# network <connected_net>   <wildcard-mask>  area   0 

访问控制列表(ACL)

标准ACL和拓展ACL的区别:

(1)扩展ACL具有更多的匹配项,包括协议类型、源地址、目的地址、端口等
(2)扩展ACL编号是100~199,2000~2699
(3)端口前要加入运算符,eq等于、neq不等于、gt大于、lt小于、range范围
1.标椎ACL

//创建ACL,方法一:
(config)# access-list <1~99>  <permit/deny> x.x.x.x <wildcard_mask> ...
//方法二:
(config)# ip access-list standard <1~99/word>
//Sequence_number 为顺序编号
(config-std-nacl)# <sequence_number> <permit/deny> ...


//进入接口绑定ACL
(config)# int <interface_id>
(config-if)#  ip access-group <acl_id> <in/out>          
2.拓展ACL
//创建拓展ACL,方法一:
(config)# access-list <100~199> <permit/deny> <protocol> ...
//方法二:
(config)# ip access-list extended <100~199/word>
(config-ext-nacl)# <sequence_number> <permit/deny> <protocol> ...

//进入接口绑定ACL
(config)# int <interface_id>
(config-if)#  ip access-group <acl_id> <in/out>    

网络地址转换(NAT)

什么是NAT?

NAT 就是将私有地址映射为公网地址。
包含三种方式:
    1. 静态转换:一对一静态映射
    2. 动态转换:内部地址随机与外网地址池建立连接,通信结束后释放IP
    3. 端口转换(PAT):内部地址通过外网IP的不同端口进行数据转发
1.静态转换
(config)# ip nat inside source static <inside_address> <outside_address>

//进入内部端口进行声明
(config)# int <inside_interface_id>
(config-if)# ip nat inside 

//进入外部端口进行声明
(config)# int <outside_interface_id>
(config-if)# ip nat outside 
2.端口地址转换(PAT)
//创建绑定ACL
(config)# access-list 1 <permit/deny> <network> <wildcard_mask>
(config)# ip nat inside source list 1 interface <interface_id> overload

//进入内部端口进行声明
(config)# int <inside_interface_id>
(config-if)# ip nat inside 

//进入外部端口进行声明
(config)# int <outside_interface_id>
(config-if)# ip nat outside 
3.动态地址转换
//创建外网地址池
(config)# ip nat pool <word> <start_ip> <end_ip> netmask <network_mask>

//创建acl并绑定
(config)# access-list 1 <permit/deny> <network> <wildcard_mask>
(config)# ip nat inside source list 1 pool <word> 

//进入内部端口进行声明
(config)# int <inside_interface_id>
(config-if)# ip nat inside 

//进入外部端口进行声明
(config)# int <outside_interface_id>
(config-if)# ip nat outside 


文章评论